home-manager/home.nix
2024-06-21 20:15:22 +02:00

76 lines
1.6 KiB
Nix

{ config, pkgs, ... }:
let
homeDir = "/home/leon";
in
{
# Home Manager needs a bit of information about you and the
# paths it should manage.
home.username = "leon";
home.homeDirectory = homeDir;
# Packages that should be installed to the user profile.
home.packages = with pkgs; [
prismlauncher # Minecraft
element-desktop # Matrix Desktop Client
tidal-hifi # Tidal Web Client
helvum # pipewire patchbay
];
programs.zsh.enable = true;
programs.bash.enable = true;
programs.git =
{
enable = true;
userName = "Leon Wilzer";
userEmail = "git@komu.boo";
aliases = {
ci = "commit";
co = "checkout";
s = "status";
};
};
programs.ssh =
let
sshDir = "${homeDir}/.ssh";
in
{
enable = true;
matchBlocks = {
"libre.moe *.libre.moe" = {
user = "leon";
identityFile = "${sshDir}/libremoe";
};
"komu.boo *.komu.boo" = {
user = "leon";
identityFile = "${sshDir}/komuboo";
};
"uni-paderborn.de upb.de *.uni-paderborn.de *.upb.de" = {
user = "lwilzer";
identityFile = "${sshDir}/unipaderborn";
};
};
};
# This value determines the Home Manager release that your
# configuration is compatible with. This helps avoid breakage
# when a new Home Manager release introduces backwards
# incompatible changes.
#
# You can update Home Manager without changing this value. See
# the Home Manager release notes for a list of state version
# changes in each release.
home.stateVersion = "24.05";
# Let Home Manager install and manage itself.
programs.home-manager.enable = true;
# X11
xsession.enable = true;
xsession.windowManager.command = "dwm";
}