77 lines
1.8 KiB
Nix
77 lines
1.8 KiB
Nix
{ ... }:
|
|
|
|
{
|
|
#imports = [
|
|
# ./theme.nix
|
|
#];
|
|
### Hyprland
|
|
wayland.windowManager.hyprland = {
|
|
enable = true;
|
|
settings = {
|
|
### DEBUG
|
|
debug = {
|
|
disable_logs = false;
|
|
};
|
|
|
|
### Refer to the wiki for more information.
|
|
### https://wiki.hyprland.org/Configuring/Configuring-Hyprland/
|
|
|
|
### Theme
|
|
source = [ "$XDG_CONFIG_HOME/hypr/mocha.conf" ];
|
|
|
|
### Fuck you NVIDIA!
|
|
cursor = {
|
|
no_hardware_cursors = true;
|
|
};
|
|
|
|
### Monitors
|
|
# See https://wiki.hyprland.org/Configuring/Monitors/
|
|
monitor = [
|
|
" , preferred, auto, 1"
|
|
"DP-1, preferred, auto, 1, bitdepth, 10"
|
|
];
|
|
|
|
### Programs
|
|
|
|
## Defaults
|
|
"$terminal" = "kitty";
|
|
"$menu" = "wofi --show drun";
|
|
|
|
## Autostart
|
|
exec-once = [
|
|
# Status bar
|
|
"waynbar"
|
|
# Display Random Wallpaper
|
|
"unlink $XDG_PICTURES_DIR/Wallpapers/current ; ln -s $XDG_PICTURES_DIR/Wallpapers/$(ls $XDG_PICTURES_DIR/Wallpapers | sort -R | tail -1) $XDG_PICTURES_DIR/Wallpapers/current && hyprpaper"
|
|
# Notification Daemon
|
|
"mako"
|
|
# Idle Manager
|
|
"hypridle"
|
|
];
|
|
|
|
### Environment Variables
|
|
env = [
|
|
"LIBVA_DRIVER_NAME,nvidia" # fNVIDIA
|
|
"XDG_SESSION_TYPE,wayland" # fNVIDIA
|
|
"GBM_BACKEND,nvidia-drm" # fNVIDIA
|
|
"__GLX_VENDOR_LIBRARY_NAME,nvidia" # fNVIDIA
|
|
"NVD_BACKEND,direct" # fNVIDIA
|
|
"ELECTRON_OZONE_PLATFORM_HINT,auto" # fNVIDIA
|
|
"XCURSOR_SIZE,24"
|
|
"HYPRCURSOR_SIZE,24"
|
|
];
|
|
|
|
### Look and Feel
|
|
# Refer to https://wiki.hyprland.org/Configuring/Variables/
|
|
# https://wiki.hyprland.org/Configuring/Variables/#general
|
|
general = {
|
|
gaps_in = 4;
|
|
gaps_out = 8;
|
|
|
|
border_size = 2;
|
|
|
|
};
|
|
};
|
|
};
|
|
}
|