48 lines
821 B
Nix
48 lines
821 B
Nix
{
|
|
config,
|
|
pkgs,
|
|
inputs,
|
|
lib,
|
|
...
|
|
}:
|
|
|
|
let
|
|
username = "lwilzer";
|
|
homeDir = "/upb/users/l/${username}/profiles/unix/cs";
|
|
in
|
|
{
|
|
imports = [
|
|
./common.nix
|
|
./firefox.nix
|
|
# ./hypr.nix
|
|
];
|
|
|
|
# Home Manager needs a bit of information about you and the
|
|
# paths it should manage.
|
|
home.username = username;
|
|
home.homeDirectory = homeDir;
|
|
|
|
programs.firefox.forcePrivateBrowsing = true;
|
|
|
|
common.userHome = homeDir;
|
|
|
|
programs.ssh.customMatchBlocks =
|
|
let
|
|
sshDir = "${homeDir}/.ssh";
|
|
in
|
|
{
|
|
"swtpra-9.cs.uni-paderborn.de" = {
|
|
user = "cocs-ansible";
|
|
identityFile = "${sshDir}/ansible";
|
|
};
|
|
};
|
|
|
|
programs.git = {
|
|
siging = {
|
|
signByDefault = true;
|
|
key = "0xBE429D525C136DEB";
|
|
};
|
|
userEmail = "lwilzer@mail.uni-paderborn.de";
|
|
};
|
|
}
|